9 posts / 0 new
Last post
Kaneswaran Avili
calling api simulator return error

I am trying to call some of the api using the simulator, like this:

curl -X GET "https://api.fortellis.io/sales/v1/elead/customers/06eb33ba-d9bf-4b0c9887... \
-H "Authorization: Basic {base64 encoded api_key:api_secret}" \
-H "Subscription-Id: test"

but I am getting this error message: "Invalid SubscriptionId or Implementation provider is not configured for the requested API.".

I also notice that the test endpoint button is not available in most api specification. can I know what is causing the error? and what is the proper way to test calling api using simulator?


farid@digitaldi...
Did you ever find out the

Did you ever find out the reason behind that error message? I'm having the exact issue. 


FortellisAdvocate
Hello, thank you for reaching
Hello, thank you for reaching out. The 'Test" Subscription is being deprecated. When you complete the request for use of and API you will be provided a specific sandbox ID that can be used with you APP and the API you requested

yuhua.chen@orbee.com
Hello, I was wondering where

Hello, I was wondering where to find this specific sandbox id? I tested with the `Test Subscription id` in my app page, but still got the same error


FortellisAdvocate
Hello Yuhua,
Hello Yuhua, Thank you for reaching out, each organization is provided a unique sandbox ID when they register the app they wish to develop. You can find additional details here for the registering of an APP: https://docs.fortellis.io/docs/tutorials/app-lifecycle/registering-apps/

yuhua.chen@orbee.com
Hi there, thanks for the

Hi there, thanks for the reply, but I still got a problem when accessing the Elead Sales Customers. Since the subscription with the value "test" has been deprecated, I use the `test subscription id` shown in my registered App. I have activated the app and configured the API to use with the app, and the status for the Elead Sales Customers API shows `active`. But I still got "Invalid SubscriptionId or Implementation provider is not configured for the requested API." when I tried to access the API. I'm really stuck and not sure what the problem is. Please help. Many thanks.


FortellisAdvocate
Hello Yuhua,
Hello Yuhua, Thank you for reaching out again. Someone from the Fortellis Engagement office will be reaching out to you shortly. There is a concern with the APIs activated within your APP and thus the test subscriptions hasn't been completed.

chris.andrews@a...
Hey Yuhua,

Hey Yuhua,

Did you ever get this figured out? I am having the same issue with multiple APIs.

Thanks


FortellisAdvocate
Hello Chris,
Hello Chris, Thank you for reaching out, we have reached out via email to discuss further.. Regards Fortellis

Add new comment